DragonFly BSD
DragonFly users List (threaded) for 2005-02
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: em driver issues

From: Matthew Dillon <dillon@xxxxxxxxxxxxxxxxxxxx>
Date: Thu, 3 Feb 2005 10:01:32 -0800 (PST)

:I have a bunch of problems regarding the em driver in 1.1-Stable. 
:I'm able to panic the system almost immediately by firing a stream
:of packets at the system and (I assume) causing an overrun condition.
:But before I tackle debugging the crash, I have some other issues 
:that might need to be cleared up first. And I also want to see if 
:anyone else is working on it so as to not duplicate the effort.
:We have a 2 port OEM card based on the 82546EB/GB chip (both have
:the same problem). The card is detected seemingly ok, but the link 
:doesn't work. A box that I'm testing with has 2 82540EM parts on the
:Motherboard and they work fine. But the 2 ports on the adapter card
:do not detect the link. Moving the cable from the 82546EB port to the
:82540EM port results in an immediate link up. The symptoms are the
:same on another MB with fxp ports onboard, so its not an interaction
:between the different type of em ports. 
:I've diff'ed the FreeBSD 4.9 code and Dragonfly's and there are many
:differences. We never used 4.8 (we went from 4.7 to 4.9) and I know
:many em driver issues were resolved from 4.7 -> 4.9, but I'm not sure 
:of how the driver was in 4.8. Before I start mucking with this, if anyone 
:has any information or has done any work on this I'd appreciate hearing
:about it. 

    I've got a bunch of boxes with the em card in it.  Could you describe
    how you are generating the packet stream to cause the panic ?

					Matthew Dillon 

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]