DragonFly BSD
DragonFly users List (threaded) for 2006-07
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: Does Java work on DragonFly?

From: walt <wa1ter@xxxxxxxxxxxxx>
Date: Mon, 17 Jul 2006 06:03:42 -0700

On Mon, 17 Jul 2006, Geert Hendrickx wrote:

> On Tue, Jul 18, 2006 at 03:53:05AM +1000, Petr Janda wrote:
> > I want to install Eclipse/RadRails, but I need JRE. I installed
> > /usr/pkgsrc/lang/sun-jre15 but it seems to be broken.
> >
> > [elevator] ~% sun15-java
> > Java HotSpot(TM) Client VM warning: Can't detect initial thread stack
> > location - find_vma failed
> > Bad system call (core dumped)
> Have you tried increasing your datasize resource limit?
> Do "ulimit -d 262144" and try again.

I posted in bugs@ last week about this same problem.  When Sun
released 1.4.2_12 for linux, I noticed the same error, but
1.4.2_11 works fine.  I've just tried all the 1.5.0 linux
versions available from Sun but they all do the same coredump.
(They work for me on linux, however.)

$ ulimit -d

So, Petr, for the moment the answer to your question is 'no'
for java 1.5.0, and 'yes' for 1.4.2_11 (and earlier).

Earlier linux java versions are available here:

The wip/jdk14 does work on DragonFly, but at the moment is
a pain to compile unless you can get the 1.4.2_11 linux
binaries someplace (I don't see them on the Sun servers
right now.)  I have the files here if you need me to
upload them somewhere.

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]