DragonFly BSD
DragonFly users List (threaded) for 2006-08
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: Problem with url2pkg

From: "Jeremy C. Reed" <reed@xxxxxxxxxxxxx>
Date: Tue, 15 Aug 2006 19:13:18 -0500 (CDT)

> > Don't run it in a directory already in use.
> >
> > cd /usr/pkgsrc # or wherever you keep it
> > mkdir -p NEW/ucarp
> > cd NEW/ucarp
> > url2pkg 
> >
> http://download.pureftpd.org/pub/ucarp/ucarp-1.2.tar.gz
> > 
> > Anyways, it doesn't not make sense to create a new 
> > package from scratch 
> > when it already exists.
> >
> > Just simply modify the existing Makefile to use the 
> > newer version. And run 
> > "bmake makesum".
> Ok, but:
> 1) how can I find the makefile for pkgsrc version of
> ucarp 1.1?
> 2) I created /usr/pkgsrc/NEW/ucarp directory and I
> tried url2pkg
> http://download.pureftpd.org/pub/ucarp/ucarp-1.2.tar.gz
> in ucarp directry, but it always retuns the message:
> "Run this in .../pkgsrc/foo/bar !

There must be some miscommunication problem.

I use url2pkg very frequently.

I just reinstalled it again (but no change as I see) and tested again.

It works fine for me using same steps as above.

If you need help, please provide exact step-by-step commands and output of 
your testing. The script tool can help with that.

Anyways, as I said before: don't use url2pkg for this. It is a waste of 
your time. Simple edit the pkgsrc/net/ucarp/Makefile to change the 
version and try "make makesum"

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]