DragonFly users List (threaded) for 2008-05
DragonFly BSD
DragonFly users List (threaded) for 2008-05
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: pkgsrc -current on DragonFly 1.13.0/i386

From: Hasso Tepper <hasso@xxxxxxxxx>
Date: Sun, 11 May 2008 19:58:04 +0300

Robert Luciani wrote:
> As Simon pointed out, many "big" packages never got compiled such as 
> OpenOffice and KDE.

KDE should compile fine for. I committed all DragonFly BSD specific 
patches to upstream before 3.5.9 release and as result 3.5 branch from 
KDE repo compiles fine without any changes. 

OpenOffice is different beast. AFAIK no work is done to port it to 
DragonFly. I really hope this will change.

> In other words 21.2% of pkg-src packages do not compile correctly as of 
> now.

Quite depressing I have to say :). But situation should be much better 
already. I had some hours to look at reports during last days and I 
reported most of big problems to pkgsrc developers. Some of them are 
already fixed (MANY thanks to Tobias Nygren).

It demonstrates how important these (hopefully regular) bulk builds are.

> Package                               Breaks Maintainer
> -----------------------------------------------------------------------
> security/heimdal                         176 lha@NetBSD.org 

Reported - http://www.netbsd.org/cgi-bin/query-pr-single.pl?number=38622

> lang/python25                            176 recht@NetBSD.org

Fixed - http://www.netbsd.org/cgi-bin/query-pr-single.pl?number=38614

> databases/db4                            106 pkgsrc-users@NetBSD.org

Fixed - http://www.netbsd.org/cgi-bin/query-pr-single.pl?number=38616

> editors/emacs                             77 markd@NetBSD.org

Will report with patch later today.

> lang/python21                             70 pkgsrc-users@NetBSD.org

Fixed - http://www.netbsd.org/cgi-bin/query-pr-single.pl?number=38617

> math/fftw                                 44 pkgsrc-users@NetBSD.org
> math/blas                                 44 adam@NetBSD.org

These need Fortran.

> devel/gnustep-objc                        26 rh@NetBSD.org

This needs Obj-C.

> misc/libcdio                              21 drochner@NetBSD.org

Reported - http://www.netbsd.org/cgi-bin/query-pr-single.pl?number=38627

Hasso Tepper

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]