DragonFly users List (threaded) for 2009-05
DragonFly BSD
DragonFly users List (threaded) for 2009-05
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Disk question

From: Tim Darby <t+dfbsd@xxxxxxxxxxxx>
Date: Fri, 15 May 2009 11:49:59 -0700

I have a machine that was running Windows XP until I recently
installed 2.2.2 on it.  This was mainly for the purpose of trying out
Hammer.  It contains a 40GB drive, which I made the boot drive and
installed with Hammer.  The other 2 drives are a 300GB Samsung IDE and
a 200GB Western Digital IDE, both connected to a SiI 0680 controller.
I've succcessfully installed Hammer on the WD drive, but the Samsung
fails as follows:

# newfs_hammer -L BACKUP /dev/ad6s1a
Volume 0 DEVICE /dev/ad6s1a     size 279.46GB
initialize freemap volume 0
ad6: WARNING - READ_DMA UDMA ICRC error (retrying request) LBA=2245359
ad6: TIMEOUT - READ_DMA retrying (0 retries left) LBA=2245359
error=84<ICRC,ABORTED> LBA=2245359
newfs_hammer: get_buffer: /dev/ad6s1a:2000000000814000 Read failed at
offset 1149583360: Input/output error

I ran a Samsung diagnostic on it and it found a DMA command timeout
problem (service code AJ27), so it appears that the drive really does
have a problem.  Just for kicks though, I tried installing UFS on this
drive and it gave me no complaints and seems to actually work.  Also,
Windows XP seemed to be working fine with this drive.  Does that make
any sense?


Copyright (c) 2003-2009 The DragonFly Project.
Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
DragonFly 2.2.2-RELEASE #0: Sat May  9 18:42:36 MST 2009
TSC clock: 1384172980 Hz, i8254 clock: 1193158 Hz
CPU: Intel(R) Pentium(R) 4 CPU 1400MHz (1384.21-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf07  Stepping = 7
real memory  = 267874304 (261596K bytes)
avail memory = 246792192 (241008K bytes)
Preloaded elf kernel "/boot/kernel" at 0xc07c5000.
Preloaded elf module "/boot/modules/acpi.ko" at 0xc07c5218.
Pentium Pro MTRR support enabled
md0: Malloc disk
pcibios: BIOS version 2.10
Using $PIR table, 9 entries at 0xc00fbbb0
ACPI: RSDP @ 0x0xfd6d0/0x0014 (v  0 DELL  )
ACPI: RSDT @ 0x0xfd6e4/0x0030 (v  1 DELL    GX400   0x00000005 ASL  0x00000061)
ACPI: FACP @ 0x0xfd718/0x0074 (v  1 DELL    GX400   0x00000005 ASL  0x00000061)
ACPI: DSDT @ 0x0xfffe5022/0x2474 (v  1   DELL    dt_ex 0x00001000 MSFT
ACPI: FACS @ 0x0xff96000/0x0040
ACPI: SSDT @ 0x0xfffe75d3/0x00BA (v  1   DELL    st_ex 0x00001000 MSFT
ACPI: BOOT @ 0x0xfd7e8/0x0028 (v  1 DELL    GX400   0x00000005 ASL  0x00000061)
npx0: <math processor> on motherboard
npx0: INT 16 interface
Using XMM optimized bcopy/copyin/copyout
acpi0: <DELL GX400  > on motherboard
acpi0: Power Button (fixed)
Warning: ACPI is disabling APM's device.  You can't run both
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_button0: <Power Button> on acpi0
fdc0: <NEC 72065B or clone> port 0x3f7,0x3f0-0x3f5 irq 6 drq 2 on acpi0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0 port 0x3f8-0x3ff irq 4 on acpi0
sio0: type 16550A
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1 port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
ppc0 port 0x778-0x77f,0x378-0x37f irq 7 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
legacypci0 on motherboard
pcib0: <Host to PCI bridge> on legacypci0
pci0: <PCI bus> on pcib0
agp0: <Intel 82850 host to AGP bridge> mem 0xf8000000-0xfbffffff at
device 0.0 on pci0
pcib1: <PCI to PCI bridge (vendor=8086 device=2532)> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <NVidia GeForce2 GTS graphics accelerator> at 0.0 irq 11
pcib2: <Intel 82801BA/CA/DB/EB/FB (ICH2/3/4/5/6) Hub to PCI bridge> at
device 30.0 on pci0
pci2: <PCI bus> on pcib2
em0: <Intel(R) PRO/1000 Network Connection, Version - 6.2.9> port
0xecc0-0xecff mem 0xff1c0000-0xff1dffff,0xff1e0000-0xff1fffff irq 10
at device 8.0 on pci2
em0: MAC address: 00:07:e9:0a:5a:1f
pci2: <unknown card> (vendor=0x16ec, dev=0x2f00) at 9.0 irq 11
atapci0: <SiI 0680 UDMA133 controller> port
mem 0xff1afc00-0xff1afcff irq 11 at device 11.0 on pci2
ata2: <ATA channel 0> on atapci0
ad4: 190782MB <WDC WD2000JB-00EVA0 15.05R15> at ata2-master UDMA100
ata3: <ATA channel 1> on atapci0
ad6: 286168MB <SAMSUNG HD300LD WK100-12> at ata3-master UDMA100
xl0: <3Com 3c905C-TX Fast Etherlink XL> port 0xe880-0xe8ff mem
0xff1af800-0xff1af87f irq 11 at device 12.0 on pci2
miibus0: <MII bus> on xl0
ukphy0: <Generic IEEE 802.3u media interface> on miibus0
ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
xl0: MAC address: 00:b0:d0:e7:df:73
isab0: <Intel 82801BA/BAM (ICH2) PCI to LPC bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci1: <Intel ICH2 UDMA100 controller> port
0xffa0-0xffaf,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 31.1 on
ata0: <ATA channel 0> on atapci1
ad0: DMA limited to UDMA33, controller found non-ATA66 cable
ad0: 38166MB <Seagate ST340014A 3.06> at ata0-master UDMA33
acd0: DVDROM <NEC DV-5800A/1.07> at ata0-slave UDMA33
ata1: <ATA channel 1> on atapci1
uhci0: <Intel 82801BA/BAM (ICH2) USB controller USB-A> port
0xff80-0xff9f irq 11 at device 31.2 on pci0
usb0: <Intel 82801BA/BAM (ICH2) USB controller USB-A> on uhci0
usb0: USB revision 1.0
uhub0: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
uhub0: 2 ports with 2 removable, self powered
pci0: <unknown card> (vendor=0x8086, dev=0x2443) at 31.3 irq 10
uhci1: <Intel 82801BA/BAM (ICH2) USB controller USB-B> port
0xff60-0xff7f irq 9 at device 31.4 on pci0
usb1: <Intel 82801BA/BAM (ICH2) USB controller USB-B> on uhci1
usb1: USB revision 1.0
uhub1: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb1
uhub1: 2 ports with 2 removable, self powered
pci0: <unknown card> (vendor=0x8086, dev=0x2445) at 31.5 irq 10
orm0: <Option ROMs> at iomem
0xc0000-0xca7ff,0xca800-0xcefff,0xcf000-0xd07ff,0xd0800-0xd3fff on
pmtimer0 on isa0
fdc1: cannot reserve I/O port range
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
ppc1: cannot reserve I/O port range
Mounting root from hammer:/dev/ad0s1a
cd0 at ata2 bus 0 target 1 lun 0
cd0: <_NEC DV-5800A 1.07> Removable CD-ROM SCSI-0 device
cd0: 33.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]