DragonFly BSD
DragonFly users List (threaded) for 2009-10
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: dfly2.4.1 nativekernel build error: -mpreferred-stack-boundary=2 is not between 4 and 12

From: "Justin C. Sherrill" <justin@xxxxxxxxxxxxxxxxxx>
Date: Tue, 13 Oct 2009 09:59:30 -0400 (EDT)

On Tue, October 13, 2009 7:11 am, Saifi Khan wrote:
> On Tue, 13 Oct 2009, YONETANI Tomokazu wrote:

>> So you've installed 64-bit version of DragonFly on your system.
>> Is your kernel config file SYNERGY based on AMD64_GENERIC, not GENERIC?
>> Cheers.
> Ah ! Thanks Yonetani.
> Indeed, the kernel config file was based on GENERIC and i was
> wondering why the machine and platform are not amd64.

This brings up an idea: should we rename GENERIC to I386_GENERIC?  Cause
if it's not going to work for amd64, then a more exact name would help.

I anticipate it's going to be some years before everything's 64-bit, so
we're going to have both config files around for some time, and reducing
potential confusion (we've already had one incident) would be good.

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]