DragonFly BSD
DragonFly users List (threaded) for 2009-10
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: [Fwd: pkgbox64 pkgsrc DragonFly 2.5.1/x86_64 2009-10-21 14:07]

From: "Simon 'corecode' Schubert" <corecode@xxxxxxxxxxxx>
Date: Thu, 22 Oct 2009 02:19:36 +0200

Justin C. Sherrill wrote:
lang/ruby18-base 269 taca@NetBSD.org

Ruby breaks because it installs files into lib/ruby/1.8/x86_64-dragonfly/, whereas pkgsrc expects them to be in lib/ruby/1.8/amd64-dragonfly/. This is because configure automatically converts amd64 to x86_64, and netbsd calls the platform (and architecture) x86_64. I think we should bite the bullet now and call it x86_64 in uname, instead of trying to hack around this in pkgsrc.


  <3 the future  +++  RENT this banner advert  +++   ASCII Ribbon   /"\
  rock the past  +++  space for low CHF NOW!1  +++     Campaign     \ /
Party Enjoy Relax   |   http://dragonflybsd.org      Against  HTML   \
Dude 2c 2 the max   !   http://golden-apple.biz       Mail + News   / \

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]