DragonFly BSD
DragonFly users List (threaded) for 2010-01
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: linuxulator update

From: Vincent Stemen <vince.dragonfly@xxxxxxxxxxx>
Date: Sat, 30 Jan 2010 00:06:30 -0600

On Fri, Nov 27, 2009 at 02:10:15PM -0000, Alex Hornung wrote:
> Hi,
> With our outdated linux emu (linuxulator) we can't run most of the software
> that can run on FreeBSD, such as newer jre/jdk, ... ( see bug report 1141
> [1] for more details).
> To actually be able to update the linuxulator, it would be very helpful to
> have LTP (Linux Test Project)[2] working on DragonFly. This is a relatively
> simple task that many end-users (as in non-developers) could do, and which
> would make it possible to identify what exactly we are lacking, what needs
> updating and once it is updated, directly testing to see if it works as
> expected. LTP would be compiled on some linux machine, and then made to run
> on our current linuxulator to identify these issues.
> If anyone would step up to do this task, we could immediately start updating
> the code with considerably less effort than without LTP. So please, if
> someone wants to start contributing without actual coding, this is a great
> opportunity which would result in great benefit for everyone.
> Cheers,
> Alex Hornung
> [1]: http://bugs.dragonflybsd.org/issue1141
> [2]: http://ltp.sourceforge.net/

After finally reading this thread, we had a friend compile
ltp-intermediate-20100119 on SUSE 11.2.  We have a strong interest in
getting the linuxulator updated so we can get the Xilinx gate array
compiler up and running on Dragonfly.

I could upload the built binary of ltp as a tar file to leaf if anybody
wants me to.


[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]