DragonFly BSD
DragonFly users List (threaded) for 2010-05
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: Updating a pkgsrc package

From: "Justin C. Sherrill" <justin@xxxxxxxxxxxxxxxxxx>
Date: Sun, 2 May 2010 11:09:22 -0400

On Sun, May 2, 2010 7:25 am, Francois Tigeot wrote:
> Hi,
> I have locally updated mail/prayer to version 1.3.2. The pkgsrc package
> is more than two years old.
> It now compiles and installs cleanly on DragonFly.
> Is there any thing I should be aware before submitting my work to the
> pkgsrc guys ? My main concern is that I do not have any NetBSD machine
> to test my changes...

You also don't have a FreeBSD, Linux, Haiku, or Solaris machine to test
on, though pkgsrc runs there...  I don't know what your changes look like,
but it may be clear whether it has a negative effect or not just from
looking at it.

A unified diff should work.  Send a PR through the support section on the
NetBSD website:


Pick "pkg" for the category.  This worked for me last time I did it.

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]