DragonFly BSD
DragonFly users List (threaded) for 2010-12
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Issue with X

From: "Garcia Rojas, Guillermo (MABE,EXTERNO)" <guillermo.garcia_rojas@xxxxxxxxxxx>
Date: Wed, 8 Dec 2010 01:44:19 -0600

Hi there,


A few days ago I installed DragonFly BSD 2.8.2-RELEASE and all went very well, but when I tried to configure X the problems came.


I have a SiS 630 integrated video card, and was running very well since DragonFly BSD 1.2, I was using basically the same xorg.conf file since then to DragonFly 2.6. This situation is very weird, cause when I did a startx, it ran the default wm, I mean the one that opens 3 windows with green borders. But when I ran it with xfce4 in .xinitrc, it shows a blank screen and can’t get out to any tty, then I had to reset the box.


Then I tried with PC-BSD 7.1.1 but never can´t launch the graphic installer, this is strange cause, months ago, I installed the same PC-BSD, same CDs into this machine and detected very well my SiS card, and now it can’t!!


FreeBSD 8.1 did the same, xorg configured and startx goes to a blank screen with no possibilities to switch with ALT+F1, F2, F3, etc.


I use the same xorg.conf I have always used for my past BSD systems, I don’t have it right now but the highlights are:


Device “sis”, with xf86-video-sis on FreeBSD 8.1

With device “vesa” it throws an error saying it can’t open the display.


The HorizSync and VertRefresh are according to the same monitor I have for at least 5 years.


I will be very thankful if someone can explain to me the cause of this weird behaviour.




Guillermo García Rojas Covarrubias

IT Operator

Triara Querétaro

Av. Epigmenio González #2

Col. Claustros del Parque

C.P. 76168

Querétaro, Querétaro


JPEG image

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]