DragonFly BSD
DragonFly users List (threaded) for 2011-01
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: Compiling with gcc -march ix86

From: Stephane Russell <srussell@xxxxxxxxxxxxxxx>
Date: Sun, 02 Jan 2011 21:31:19 -0500

The main reason is that the hardware drivers has been ported to NetBSD
for Asterisk 1.4. 1.6 BSD drivers are still work in progress for what I

Maybe I should take a look at the DAHDI port for FreeBSD. It's a
replacement for zaptel drivers and seems to be used for Asterisk 1.8 in
FreeBSD, as well as for 1.6 and 1.4. I'll see.



Le 2010-12-26 03:01, Francois Tigeot a écrit :
> On Fri, Dec 24, 2010 at 05:34:38PM -0500, Stephane Russell wrote:
>> I'm actually trying to compile asterisk on DFBSD. It needs to compile
>> with the compiler option -march=ix86, with x>3 (gcc spec). But DFBSD
>> "uname -m" is returning systematically "i386". Is their a workaround for
>> that, that would allow me to compile without hacking the autotools scripts?
> Why don't you try asterisk18 from pkgsrc -head ?
> It builds fine out-of the box on DragonFly/i386.

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]