DragonFly BSD
DragonFly users List (threaded) for 2011-04
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: Fwd: pkgbox64 pkgsrc 2011Q1 DragonFly 2.10.0/x86_64 2011-04-12 03:54

To: Justin Sherrill <justin@xxxxxxxxxxxxxxxxxx>
From: Brian Gianforcaro <b.gianfo@xxxxxxxxx>
Date: Sun, 24 Apr 2011 01:20:01 -0400

On 4/12/11 1:13 PM, Justin Sherrill wrote:
Packages breaking the most other packages

Package                               Breaks Maintainer
pkgtools/rpm2pkg                         128 tron@NetBSD.org
databases/postgresql84-client            103 adam@NetBSD.org
multimedia/xine-lib                       62 pkgsrc-users@NetBSD.org
lang/ocaml                                37 adam@NetBSD.org
lang/mono                                 31 kefren@NetBSD.org
print/cups                                21 sbd@NetBSD.org
sysutils/libgtop                          18 pkgsrc-users@NetBSD.org
devel/libthrift                            9 tonnerre@NetBSD.org
www/w3m                                    7 uebayasi@NetBSD.org
textproc/cabocha                           7 obache@NetBSD.org

I looked into a couple of the big breakers to see if their was anything I could fix.

pkgtools/rpm2pkg was fixed for DragonFly in master later in the day on April 12th. Just missed it :)

lang/ocaml has an upstream fix they are releasing in 3.1	2.1
BUG: http://caml.inria.fr/mantis/view.php?id=5237

sysutils/libgtop had a fix April 13 th, not sure if it pertains to DragonFly or not.

print/cups seems like a silly linking error, but I didn't look to much further into it.

I'm looking into lang/mono now, I know this has been a sort of on going project to get it to build on DragonFly.

It's pretty awesome how close that brings us to relatively few broken packages. I remember when were using pacman wayyyy back, It's come a long way :)

- Brian

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]