DragonFly BSD
DragonFly users List (threaded) for 2012-03
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: Removing 2.6 packages, switching to pkgsrc-2012Q1 packages

From: Justin Sherrill <justin@xxxxxxxxxxxxxxxxxx>
Date: Thu, 29 Mar 2012 08:22:16 -0400

On Thu, Mar 29, 2012 at 5:38 AM, Pierre Abbat <phma@phma.optus.nu> wrote:
> On Wednesday, March 28, 2012 22:39:22 Justin Sherrill wrote:
>> The people this would inconvenience is anyone upgrading from 3.0.1 or
>> 3.0.2 to 3.0.3; your binary package target would change to a newer
>> release, so you would end up needing to upgrade your pkgsrc software,
>> if you're installing with binary packages.   If you only build pkgsrc
>> software from source, you can move to 2012Q1 at your leisure.
> Are you saying that there's a new version of pkg_radd or pkgin, and the old
> version won't handle new packages?

No.  3.0.x is using pkgsrc-2011Q4.  If I build pkgsrc-2012Q1 packages
for 3.0.3, you will be getting newer binary packages.  That is all.

For example, let's say package A depended on package B version 5.  You
have packages A and B installed.

You upgrade to 3.0.3, with pkgsrc-2012Q1, with newer versions of some

You install package C, which depends on B version 6.  This will mean
you'd need to also need to upgrade to the new version of B, since C
depends on B, and a new version of A, since A depends on B.

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]