DragonFly BSD
DragonFly bugs List (threaded) for 2004-08
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: Problem with CUPS?

From: Adam K Kirchhoff <adamk@xxxxxxxxxxxx>
Date: 20 Aug 2004 12:00:01 GMT

Adam K Kirchhoff <adamk@xxxxxxxxxxxx> wrote:
> Matthew Dillon wrote:

>>:Has anyone had any issues with their machines locking up soon after
>>:cups starts up? :-)  Nothing shows up on the console (ie. no debugger),
>>:but my entire machine locks solid.
>>    Adam (and anyone with the freeze-on-serial-port or freeze-on-CUPS-start
>>    problem), do me a favor and try some things:
>>    (1) rename /dev/ttyd0, ttyd1, ttyd2, and ttyd3 to something else, e.g.
>>	/dev/ttyd0.x, /dev/ttyd1.x, ...  Then see if CUPS starts up.

> It does.

>>    (2) Restore the original namings and try to run a getty on ttyd0 by
>>	editing /etc/ttys and HUPing init.  See if that crashes the machine.

> Heh...  I can do one better for you.  For a little while now, when I 
> boot with the console going through the serial port, it doesn't get 
> beyond mounting / before the machine locks up.  I never put 2+2 together 
> with the posts I read about the crash when running getting on ttyd0, 
> though I should have.

>>    (3) If it does crash the machine, reboot (single user) and fix ttys back,
>>	remove the last modification I had made to the serial port code 
>>	(see patch below), and try running a getty on ttyd0 again to see if
>>	it still crashes.

> I'll patch it now and rebuild the entire system tonight (haven't done 
> that in a while)..  I'll try and get back to you tomorrow.

That patch works fine here.  I can now launch CUPS without any issues.


[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]