DragonFly BSD
DragonFly bugs List (threaded) for 2005-03
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: ipv4 connection problems

From: Matthew Dillon <dillon@xxxxxxxxxxxxxxxxxxxx>
Date: Sat, 5 Mar 2005 18:37:48 -0800 (PST)

:Over the past few weeks I've been having a problem with Apache not
:responding to port it's listening on.  After some investigation, I
:was able to determine that it was only happening on ipv4.  IPv6 was
:working just fine.  If I restarted the server, everything would be fine
:for about an hour or so (depending on traffic), and then it would
:start up again.  I figured this was an Apache problem, since it was
:only happening with my web server.
:Today, I was stressing out my ftp server (the vanilla base version),
:and I saw that it was doing the same thing my web server was doing:
:box:~% telnet -4 theshell.com 21
:telnet: connect to address Operation timed out
:telnet: Unable to connect to remote host
:And without doing anything...
:box:~% telnet -4 theshell.com 21
:Connected to theshell.com.
:Escape character is '^]'.
:220 box.theshell.com FTP server (Version 6.00LS) ready.
:221 Goodbye.
:Connection closed by foreign host.
:Note:  This is not a network connectivity issue since those telnets
:are on the same box (box is
:Again, ipv6 seems to work just fine.  Other than this, I don't really
:know what other information I can provide that can help in finding
:where the problem is.  Any thoughts?

    You need to do a bit more investigation.  Use tcpdump on the server
    to see if the machine is even *receiving* the connection attempt that
    is timing out on you, and check that your Apache has not hit its 
    programmed simultanious connection limit, controlled by its config
    file (there's an apachectl command that will do that).

					Matthew Dillon 

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]