DragonFly BSD
DragonFly kernel List (threaded) for 2004-05
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: apt-get

From: Rahul Siddharthan <rsidd@xxxxxxxxx>
Date: 31 May 2004 14:24:49 GMT

>Rahul Siddharthan wrote:
>> Related to that, apt-get can handle multiple versions of the same
>> package;
>Really?  Then could you explain to me why debian has packages like libgtk1.2
>and libgtk2.0-0 if it can handle multiple versions of the same package

Because libgtk1.2 isn't obsolete yet, some people may need to install
both (and you can do so).  You can't install libgtk 2.0, 2.2 and 2.4
simultaneously though.  On FreeBSD, once libgtk 2.4 enters the ports
tree, libgtk 2.2 goes away.  On Debian, both versions exist, but the
default changes depending on which version of Debian you're running. 

Another example is kde: you don't need both kde2 and kde3.  On debian
stable, apt-get install kde will install kde2; on unstable, the same
command will install kde3.  You don't need to specify the version, as
you did on FreeBSD back when it had both in the ports tree.  

But if you specifically want the unstable version when it isn't the
default, you can use -t unstable.

Most packages between testing and unstable have minor version
differences.  But nothing stops you installing unstable packages on a
testing system (or, indeed, vice versa).  On rare occasions when there
is a problem, it stops with "package x version y required but version
z to be installed"; the problem isn't that the needed version doesn't
exist but that it can't be installed without breaking the system.


[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]