DragonFly BSD
DragonFly kernel List (threaded) for 2004-05
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: apt-get

From: Gabriel Ebner <ge@xxxxxxxxxxxxxxx>
Date: Mon, 31 May 2004 18:25:25 +0200


Rahul Siddharthan wrote:
> On Debian, both versions exist, but the
> default changes depending on which version of Debian you're running.

It's not exactly a "default".  The reason that multiple versions of a
package exist _on_a_server_ at the same time is solely space (it's
obviously more efficient to store libgtk1.2-1.2.10-16 only once instead of
twice when both sid and sarge use the same version).

This, however, does not imply that you can use two versions of the same
library with the _same_name_ on a single system.  You have to append a
version number to the package name under debian to be able to install
multiple packages at the same time.

> Another example is kde: you don't need both kde2 and kde3.  On debian
> stable, apt-get install kde will install kde2; on unstable, the same
> command will install kde3.

This is has nothing to do with the ability to have multiple packages with
different versions but the same name.  I think you overestimate a bit what
apt-get does.  kde is just a convenience package that indirectly depends on
e.g. kdelibs4.

> You don't need to specify the version, as 
> you did on FreeBSD back when it had both in the ports tree.

As I said, a convenience meta-package, which just has a couple of
dependencies, nothing special there.  Furthermore debian only allows you to
install multiple library versions at the same time (because they have names
like kdelibs4), but not the applications (again because of their names:
e.g. kcharselect; <- no version number).

> But if you specifically want the unstable version when it isn't the
> default, you can use -t unstable.

Which is a bit of a hack, as it just allows you to select between three
distributions (i.e. sid, testing, stable).  A package system that allows
you to install multiple packages with the same name allows you to select
among all versions that are currently in the tree (i.e. often more than 3).

> Most packages between testing and unstable have minor version
> differences.  But nothing stops you installing unstable packages on a
> testing system (or, indeed, vice versa).  On rare occasions when there 
> is a problem, it stops with "package x version y required but version
> z to be installed"; the problem isn't that the needed version doesn't
> exist but that it can't be installed without breaking the system.

There's nothing special about that.  I think even slackware allows you to
"backport" packages from CURRENT.

However, I conclude, apt-get doesn't allow you to install multiple packages
with the same name where just the version number is different.


Gabriel Ebner - reverse "ta.renbeleirbag@eg"

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]