DragonFly BSD
DragonFly kernel List (threaded) for 2012-03
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Removing 2.6 packages, switching to pkgsrc-2012Q1 packages

From: Justin Sherrill <justin@xxxxxxxxxxxxxxxxxx>
Date: Wed, 28 Mar 2012 22:39:22 -0400

Here's a plan of what I'm going to do in the next little while:

- We have 2.6 binary packages still available.  I don't think anyone
is using them at this point, and building from source is still
possible even with these missing.  I will delete them soon.

- The next quarterly release of pkgsrc, 2012Q1, will be out soon.
We'll probably have a DragonFly 3.0.3 release soon too.  My plan is to
change the /usr/Makefile pkgsrc targets to point at 2012Q1 instead of
2011Q4, and build packages for 3.0.3 from 2012Q1.  This way anyone
using 3.0.1 or 3.0.2 can still pull down binary packages that match
what they have in /usr/pkgsrc, but we still get to take advantage of
the improvements in 2012Q1 (thanks to John Marino, there's a lot more
working packages.)

The people this would inconvenience is anyone upgrading from 3.0.1 or
3.0.2 to 3.0.3; your binary package target would change to a newer
release, so you would end up needing to upgrade your pkgsrc software,
if you're installing with binary packages.   If you only build pkgsrc
software from source, you can move to 2012Q1 at your leisure.

Here's the scenario, in total:

Installing 3.0.3: you get pkgsrc-2012Q1 binary packages and as
/usr/pkgsrc.  Normal.

Upgrading from 2.10 to 3.0.3: Normal.  You slowpoke.

Upgrading from 3.0.1/3.0.2 to 3.0.3 and you use pkg_radd: you will get
newer packages in binary form than what you get from /usr/pkgsrc,
until you update to the 2012Q1 branch in /usr/pkgsrc.  You will then
probably need to upgrade installed pkgsrc packages when next adding
software, because of dependencies.  Lookit the pkgsrc page on the
website if you're unsure of how to upgrade:

Upgrading from 3.0.1/2 to 3.0.3 and you do not use pkg_radd: Normal.

Clear as dirt!  I think this is relatively minor, but I want to
surprise people as little as possible.

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]