DragonFly BSD
DragonFly users List (threaded) for 2005-01
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: linuxpluginwrapper, how to install?

From: YONETANI Tomokazu <qhwt+dfly@xxxxxxxxxx>
Date: Wed, 5 Jan 2005 08:16:25 +0900

On Tue, Jan 04, 2005 at 04:58:41PM -0600, Guillermo Garcia Rojas wrote:
> > The libmap patch adjusted for DragonFly is also available at
> > http://leaf.dragonflybsd.org/~y0netan1/libmap_dfly.diff.gz
> Man, I don't know what this patch does or what I did wrong:
> I did:
> #cd /usr/src
> #gunzip /tmp/libmap_dfly.diff.gz
> #patch -p0 < /tmp/libmap_dfly.diff
> And in some point said:
> file to patch: 
> I type: libexec/something, for 2 or 3 files.

No, in general you should not proceed if patching failed or you're going
to mess up your system. The patch is supposed to be applied under
/usr/src/libexec/rtld-elf. The dfport override should have told you the
right operation(but somehow the web server was not functioning when you
tried to fetch it, sorry about that). I put it on leaf:


> And after the patch was in all my DF suffered a big core dumped, 
> all my applications and system drop a core, leaving my system
> useless.

Try the following as root
(assuming you didn't `make install' more than once)
# cd /usr/libexec
# mv ld-elf.so.1.old ld-elf.so.1

If this doesn't work, you need to reinstall from the Live CD.

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]