DragonFly BSD
DragonFly users List (threaded) for 2005-04
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: fetchmail + mutt + maildir => lost messages

From: Johannes Hofmann <Johannes.Hofmann@xxxxxx>
Date: 21 Apr 2005 18:12:09 GMT

Christopher Weimann <cweimann@xxxxxxxxx> wrote:
> On 04/20/2005-06:26PM, Johannes Hofmann wrote:
>> Yes it's odd, but it might just be a bug in qmail-inject, 
> qmail-inject doesn't actually touch the maildir.  That would be 
> qmail-local. 

That's true.

>> mutt, or me  
>> accidentally hitting wrong keys in mutt...
> Are you loosing old messages out of the folder?  Or is it that
> just the new messages from fetchmail that aren't showing up?

I was loosing old messages of the folder.

> I can't think of anyway for qmail to cause this if it is old
> messages disapearing from a maildir.  That would mean they
> are being removed from the Maildir/cur directory.  qmail-local
> only touches Maildir/tmp and Maildir/new.

Yes I can't really think of a way how qmail-local could cause that problem.

> Whats in your .qmail file?  I'm betting you have some sort of
> program delivery such as procmail/maildrop/whatever.  Even that
> still doesn't quite add up because just like qmail-local they
> wouldn't need to touch Maildir/cur to deliver new mail.

My .qmail is empty and I do not have procmail or maildrop installed.
I have no idea what is happening here. I just tried to deliver thausends of
mails locally while using mutt and I did not experience any problems.


[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]