DragonFly BSD
DragonFly users List (threaded) for 2006-07
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: jdk under 1.4?

From: walt <wa1ter@xxxxxxxxxxxxx>
Date: Sun, 09 Jul 2006 15:27:39 -0700

Jon Hamilton wrote:
> I finally got around to upgrading from 1.2 to 1.4 (via reinstall and copying
> some data around).  Most everything went smoothly, but I am struggling a little
> with one app which uses java.  Under 1.2 I had jdk-1.4.2p6_4 installed from 
> ports, and it worked fine.  I can't find anything under pkgsrc which will 
> build anything similar...

What you need is the wip (work-in-progress) pkgsrc tree, which has a
DragonFly-compilable jdk14 port:


The jdk14 port hasn't changed for several months, so just 'Downloading a
snapshot' should be fine.  You don't need the latest from CVS unless you
are curious to explore further.

Once you have the 'wip' sources installed in /usr/pgksrc/wip, just:
#cd /usr/pkgsrc/wip/jdk14

If I recall correctly you need to download the jdk sources from Sun,
plus the patchset from http://www.eyesbeyond.com/freebsddom/java/
before the port will build, but the instructions should be printed
out when you do the 'bmake'.

I'm really not sure why the 'wip' jdk hasn't been promoted to the
main pkgsrc tree.  Geert or Joerg, any idea?

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]