DragonFly BSD
DragonFly users List (threaded) for 2010-02
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: hammer upgrade clarification

From: Matthew Dillon <dillon@xxxxxxxxxxxxxxxxxxxx>
Date: Tue, 2 Feb 2010 10:42:19 -0800 (PST)

    Ok, a few things.  First, note that the HAMMER fs in the DragonFly
    2.4.x RELEASE only goes up to version 2.  The HAMMER fs in the
    development branch goes up to version 4.  So if you upgrade to
    version 4 you have to use a development kernel and you cannot go
    back to a 2.4.x release kernel.

    The next releases 2.6.x in March will of course be able to go up to
    version 4.

    In terms of upgrading, the version applies to the WHOLE filesystem,
    including all of its PFSs.  So you only need to upgrade the base
    mount.  You do not need to upgrade each PFS.

    In terms of mirror streams it is probably a good idea to kill the
    stream, upgrade, then restart the stream.  That said I can't think of
    anything detrimental if the stream were left running.

    BUT!  Be careful, the target HAMMER filesystem must be at least the
    same or higher version than the source HAMMER filesystem w/ regards to
    any mirroring streams.  Upgrade your target filesystems first.

					Matthew Dillon 

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]