DragonFly BSD
DragonFly users List (threaded) for 2011-03
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: wxWidgets 2.9

From: Pierre Abbat <phma@xxxxxxxxxxxxx>
Date: Thu, 10 Mar 2011 13:21:58 -0500

On Thursday 10 March 2011 09:39:01 Ed Berger wrote:
> "unknown system type" errors are common when compiling software
> from outside of pkgsrc with a configure script.  These scripts often
> call two others
> called config.guess and config.sub to determine how to support your
> "system".
> First try replacing the config.guess and config.sub scripts that came
> with the package
> with new ones from GNU which are dragonfly aware, or find the ones that
> your pkgsrc
> uses when it replaces them as part of its process..  If that's not
> enough to be recognized, you may haveto manually edit the configure.in
> to include dragonfly and run autoconf
> to generate a new  ./configure script for the package.

I had checked config.sub, which does know something about DragonFly, but 
forgot about config.guess. At the end of configure is a list of OSes, to 
which I added DFly, and it went further, but then it stopped in src/expat. So 
I copied config.guess and config.sub to that directory and tried again. It 
started compiling, but now got this error:

/usr/local/src/wxWidgets-2.9.1/bk-deps g++ -c -o 
wxscintilla_Editor.o -DNDEBUG -I./src/stc/scintilla/include  -I./src/stc/scintilla/src -DWXUSINGDLL -D__WX__  -D__WXX11__ -DSCI_LEXER -DLINK_LEXERS  -D_FILE_OFFSET_BITS=64 -I/usr/local/src/wxWidgets-2.9.1/lib/wx/include/x11univ-unicode-static-2.9 -I./include -I/usr/pkg/include -I/usr/pkg/include  -DWX_PRECOMP -pthread -O2 -fno-strict-aliasing -pthread -I/usr/pkg/include/pango-1.0 -I/usr/pkg/include -I/usr/pkg/include/glib/glib-2.0 -I/usr/pkg/lib/glib-2.0/include -I/usr/pkg/include/freetype2 -pt
hread -I/usr/pkg/include/pango-1.0 -I/usr/pkg/include/freetype2 -I/usr/pkg/include -I/usr/pkg/include/glib/glib-2.0 -I/usr/pkg/lib/glib-2.0/include -pthread -I/usr/pkg/include/pango-1.0 -I/usr/pkg/include/glib/glib-2.0 -I/usr/pkg/lib/glib-2.0/include ./src/stc/scintilla/src/Editor.cxx
. /include/wx/wxcrtbase.h: In function 'wchar_t* wxStrdup(const wchar_t*)':
. /include/wx/wxcrtbase.h:749: error: 'wcsdup' was not declared in this scope
*** Error code 1

Stop in /usr/local/src/wxWidgets-2.9.1.

La sal en el mar es más que en la sangre.
Le sel dans la mer est plus que dans le sang.

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]