DragonFly BSD
DragonFly users List (threaded) for 2012-02
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: wip/jdk15 does not build in pkgsrc-2011Q4 DFBSD 3.0

From: "peeter (must)" <karu.pruun@xxxxxxxxx>
Date: Sun, 26 Feb 2012 14:04:16 +0000

Many thanks to you guys for help! I succeeded in building wip/jdk16 on
3.0.1 x86_64. The wip/jdk15 was a prerequisite for wip/jdk16.

I used a layman's approach suggested by Goetz, when wip/jdk15
compilation fails on error, then

cd /usr/pkgsrc/wip/jdk15/work/.buildlink/include
ln -s freetype2/freetype freetype

and then continue building wip/jdk16 according to Francois Tigeot instructions,


openjdk7: thanks for these notes. It would be very interesting to hear
about progress on openjdk7 and have a fixed package. I'll try a build
over the next few days.

Btw, the freetype v1/v2 issue seems not peculiar to jdk, it affects
many other packages as well in pkgsrc.

Cheers, Peeter


On Sat, Feb 25, 2012 at 11:22 AM, Goetz <info@xxxxxxxxxxxx> wrote:
> On Fri, Feb 24, 2012 at 05:59:05PM +0000, peeter (must) wrote:
>> Hi all
>> wip/jdk15 (pkgsrc-wip-20120223-snapshot.tar.gz) does not build on
>> pkgsrc-2011Q4 in DFBSD 3.0.1 x86_64 (used to build on 2.10, don't know
>> branch though). There seems to be a problem with finding
> I have no idea, how this buildlink stuff is supposed to work, and
> cannot propose a patch, but those manual steps work for me:
>  pushd /usr/obj/pkgsrc/wip/jdk15/work/.buildlink/include
>  ln -s freetype2/freetype .
>  popd
>  bmake

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]