DragonFly BSD
DragonFly kernel List (threaded) for 2011-09
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: DragonFly versioning plan

From: Justin Sherrill <justin@xxxxxxxxxxxxxxxxxx>
Date: Tue, 13 Sep 2011 22:22:50 -0400

We could do that - technically, a forced install of a newer
pkg_install build from binary would work.  It still requires a
separate step from the user to remove that stopping point, and I'd
like updating to _always_ work, in general.

My opinion is that required updated pkgsrc tools should be considered
dependencies the same as with other software, and should get installed
when available and needed, same as any other part.  That doesn't
happen with pkgsrc - yet.

On Tue, Sep 13, 2011 at 12:46 AM, Matthew Dillon
<dillon@apollo.backplane.com> wrote:
>    This 'pristine' install from scratch is something we already generate
>    when we are doing a pkgsrc bulk build, its the first thing we do before
>    we start the bulk build process (building the bootstrap and a few selected
>    additional utilities).  We'd just package that up as a separate entity
>    that the user script can download separately, before moving on to the
>    bulk build.

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]